summaryrefslogtreecommitdiff
path: root/nixos/tests/all-tests.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/all-tests.nix')
-rw-r--r--nixos/tests/all-tests.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/nixos/tests/all-tests.nix b/nixos/tests/all-tests.nix
index f9e2df5..adeaf65 100644
--- a/nixos/tests/all-tests.nix
+++ b/nixos/tests/all-tests.nix
@@ -41,16 +41,14 @@ builtins.mapAttrs
testers.runNixOSTest (
{
inherit name;
+ imports = value.imports ++ [ dsl ];
testScript = ''
start_all()
substituter.wait_for_unit("nix-serve.service")
builder.succeed("dag-test")
'';
}
- // value
- // {
- imports = value.imports ++ [ dsl ];
- }
+ // builtins.removeAttrs value [ "imports" ]
)
)
{