summaryrefslogtreecommitdiff
path: root/nixos/tests/all-tests.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/all-tests.nix')
-rw-r--r--nixos/tests/all-tests.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/nixos/tests/all-tests.nix b/nixos/tests/all-tests.nix
index f7e8325..4825d4a 100644
--- a/nixos/tests/all-tests.nix
+++ b/nixos/tests/all-tests.nix
@@ -10,6 +10,20 @@ let
nodes.d.inputs.c = { }; # d->c
};
+ # A
+ # |
+ # B
+ # |
+ # C
+ transitive.dag = {
+ nodes.a = {
+ goal = true;
+ inputs.b = { };
+ };
+ nodes.b.inputs.c = { };
+ nodes.c = {};
+ };
+
# A B C D
# \ | / |
# U V W
@@ -89,6 +103,26 @@ builtins.mapAttrs
];
};
+ transitive-unbuilt-3 = {
+ imports = [
+ {
+ dag = {
+ test.unconstrained.builds = 3;
+
+ constraints.builds = 2;
+ test.constrained.builds = 0;
+
+ nodes = {
+ a.test.needed = true;
+ b.test.needed = true;
+ c.test.needed = true;
+ };
+ };
+ }
+ transitive
+ ];
+ };
+
sunset-unbuilt-7 = {
imports = [
{