summaryrefslogtreecommitdiff
path: root/nixos/tests/all-tests.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/all-tests.nix')
-rw-r--r--nixos/tests/all-tests.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/nixos/tests/all-tests.nix b/nixos/tests/all-tests.nix
index b0373da..68342d6 100644
--- a/nixos/tests/all-tests.nix
+++ b/nixos/tests/all-tests.nix
@@ -1,4 +1,4 @@
-{ nixos-lib, pkgs }:
+pkgs:
let
dsl = ./dsl.nix;
@@ -54,10 +54,9 @@ in
builtins.mapAttrs
(
name: value:
- nixos-lib.runTest (
+ pkgs.testers.runNixOSTest (
{
inherit name;
- hostPkgs = pkgs;
testScript = ''
start_all()
substituter.wait_for_unit("nix-serve.service")