aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/dsl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/dsl.nix')
-rw-r--r--nixos/tests/dsl.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/tests/dsl.nix b/nixos/tests/dsl.nix
index 1fc1fbc..0013424 100644
--- a/nixos/tests/dsl.nix
+++ b/nixos/tests/dsl.nix
@@ -1,3 +1,4 @@
+{ nix }:
{ lib, config, ... }:
let
@@ -92,7 +93,7 @@ in
config.nodes.builder =
{ pkgs, ... }:
let
- evanix = pkgs.callPackage ../../package.nix { };
+ evanix = pkgs.callPackage ../../package.nix { inherit nix; };
scope = pkgs.lib.makeScope pkgs.newScope scope-fun;
configJson = (pkgs.formats.json { }).generate "nix-dag.json" config.dag;