aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-10-14 18:37:24 +0530
committersinanmohd <sinan@sinanmohd.com>2024-10-14 20:55:09 +0530
commita69a323496a0206ca4528c26524a57ecb97ddf7a (patch)
tree1d9dc43e0911c68424fde8f9a8925a3f2236295a /flake.nix
parentdd40ef157b64aa6d2b3032f2d97468aae31747ed (diff)
flake: initHEADmaster
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..608fc48
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,40 @@
+{
+ description = "/comfy/ subtitles for mpv";
+
+ inputs.nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
+
+ outputs =
+ { self, nixpkgs }:
+ let
+ lib = nixpkgs.lib;
+
+ forSystem =
+ f: system:
+ f {
+ inherit system;
+ pkgs = import nixpkgs { inherit system; };
+ };
+
+ supportedSystems = lib.systems.flakeExposed;
+ forAllSystems = f: lib.genAttrs supportedSystems (forSystem f);
+ in
+ {
+ devShells = forAllSystems (
+ { system, pkgs }:
+ {
+ default = pkgs.mkShell {
+ buildInputs = with pkgs; [
+ lua-language-server
+ nixfmt-rfc-style
+ stylua
+ lua
+ ];
+
+ shellHook = ''
+ export PS1="\033[0;35m[ ]\033[0m $PS1"
+ '';
+ };
+ }
+ );
+ };
+}