aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..608fc48
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,40 @@
+{
+ description = "/comfy/ subtitles for mpv";
+
+ inputs.nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
+
+ outputs =
+ { self, nixpkgs }:
+ let
+ lib = nixpkgs.lib;
+
+ forSystem =
+ f: system:
+ f {
+ inherit system;
+ pkgs = import nixpkgs { inherit system; };
+ };
+
+ supportedSystems = lib.systems.flakeExposed;
+ forAllSystems = f: lib.genAttrs supportedSystems (forSystem f);
+ in
+ {
+ devShells = forAllSystems (
+ { system, pkgs }:
+ {
+ default = pkgs.mkShell {
+ buildInputs = with pkgs; [
+ lua-language-server
+ nixfmt-rfc-style
+ stylua
+ lua
+ ];
+
+ shellHook = ''
+ export PS1="\033[0;35m[ ]\033[0m $PS1"
+ '';
+ };
+ }
+ );
+ };
+}