diff options
author | sinanmohd <sinan@sinanmohd.com> | 2024-01-08 23:09:42 +0530 |
---|---|---|
committer | sinanmohd <sinan@sinanmohd.com> | 2024-01-08 23:29:53 +0530 |
commit | f8cea6f6c8a8ce35533d7fa978dbff8cd5427b7c (patch) | |
tree | b87d5da18c6f86d3a931a88370f41421833e9814 /common.nix | |
parent | 119d8d504f435b552e548a9130ae96a2a3721dff (diff) |
modules/userdata: refactor
Diffstat (limited to 'common.nix')
-rw-r--r-- | common.nix | 22 |
1 files changed, 22 insertions, 0 deletions
@@ -2,6 +2,7 @@ let host = config.networking.hostName; + user = config.userdata.user; in { disabledModules = [ @@ -32,6 +33,27 @@ in }; }; + users.users.${user} = { + extraGroups = [ "wheel" ]; + packages = with pkgs; [ + bc + unzip + htop + curl + file + dig + mtr + nnn + ps_mem + brightnessctl + ]; + + openssh.authorizedKeys.keys = [ + "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIDCeMXhkjm9CabbA/1xdtP9bvFEm8pVXPk66NmI9/VvQ sinan@vex" + "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIL8LnyOuPmtKRqAZeHueNN4kfYvpRQVwCivSTq+SZvDU sinan@cez" + ]; + }; + time.timeZone = "Asia/Kolkata"; networking.useDHCP = false; environment = { |