summaryrefslogtreecommitdiff
path: root/home/wayland/modules/foot.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-08 06:15:39 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-08 07:10:59 +0530
commit92c8ab73bf974457ea1dc720b3fe6876496294c4 (patch)
tree907bd411605ff6c793a41ec442eacc3de5b8ca5a /home/wayland/modules/foot.nix
parentc82ff3c17a1787be9348c3939284c57093da8b2f (diff)
home/wayland/sway: properly use `global.font`
Diffstat (limited to 'home/wayland/modules/foot.nix')
-rw-r--r--home/wayland/modules/foot.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/home/wayland/modules/foot.nix b/home/wayland/modules/foot.nix
index 77299aa..5f6c898 100644
--- a/home/wayland/modules/foot.nix
+++ b/home/wayland/modules/foot.nix
@@ -1,8 +1,7 @@
{ config, lib, ... }: let
font = config.global.font.monospace.name
- + ":size="
+ lib.optionalString (config.global.font.monospace.size != null)
- (builtins.toString config.global.font.monospace.size);
+ ":size=" + builtins.toString config.global.font.monospace.size;
in {
programs.foot = {
enable = true;