summaryrefslogtreecommitdiff
path: root/home/wayland/modules/zathura.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-04-30 21:23:53 +0530
committersinanmohd <sinan@sinanmohd.com>2024-04-30 21:23:53 +0530
commit3fc51de5171feb362b8373273c3e82de2a70e076 (patch)
treeeb3117b25593dd9b13c67bdd36a7c57407130c96 /home/wayland/modules/zathura.nix
parent2489ed494af18c22d7cd100f4fbbe7ca9a659f6e (diff)
home: home-manager -> home
Diffstat (limited to 'home/wayland/modules/zathura.nix')
-rw-r--r--home/wayland/modules/zathura.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/home/wayland/modules/zathura.nix b/home/wayland/modules/zathura.nix
new file mode 100644
index 0000000..6751f32
--- /dev/null
+++ b/home/wayland/modules/zathura.nix
@@ -0,0 +1,15 @@
+{ lib, ... }: {
+ programs.zathura = {
+ enable = true;
+
+ mappings = {
+ "f" = "toggle_fullscreen";
+ "[fullscreen] f" = "toggle_fullscreen";
+ };
+ options = {
+ font = lib.mkDefault "Sans";
+ statusbar-basename = true;
+ selection-clipboard = "clipboard";
+ };
+ };
+}