summaryrefslogtreecommitdiff
path: root/home/wayland/modules/zathura.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-03 20:50:58 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-03 21:25:00 +0530
commitd4f7650cd0735d1fe9173530cc31c24b65ed44ff (patch)
tree82086000936fed44120734ce2308207478d73954 /home/wayland/modules/zathura.nix
parent279ff6251173e161cc50d8ae03cb3cd2e90a61a4 (diff)
global/font: init
Diffstat (limited to 'home/wayland/modules/zathura.nix')
-rw-r--r--home/wayland/modules/zathura.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/home/wayland/modules/zathura.nix b/home/wayland/modules/zathura.nix
index 8437e80..9a013da 100644
--- a/home/wayland/modules/zathura.nix
+++ b/home/wayland/modules/zathura.nix
@@ -1,4 +1,9 @@
-{ lib, ... }: {
+{ config, lib, ... }: let
+ font = config.global.font.sans.name
+ + " "
+ + lib.optionalString (config.global.font.sans.size != null)
+ (builtins.toString config.global.font.sans.size);
+in {
programs.zathura = {
enable = true;
@@ -7,7 +12,7 @@
"[fullscreen] f" = "toggle_fullscreen";
};
options = {
- font = lib.mkDefault "Sans";
+ inherit font;
statusbar-basename = true;
selection-clipboard = "clipboard";
database = "sqlite";