summaryrefslogtreecommitdiff
path: root/hosts/kay/modules/matrix_sliding_sync.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-12-23 16:11:03 +0530
committersinanmohd <sinan@sinanmohd.com>2023-12-23 17:10:00 +0530
commit4d1a6b9e5edd81e89e71fa98a1ab618bcd6ada31 (patch)
tree52da1b6cad3ba2a8fea53579f755be77fb49327b /hosts/kay/modules/matrix_sliding_sync.nix
parentf19894dd2788dd514b710b7593ab0d84972e76a1 (diff)
kay/matrix_sliding_sync: init
Diffstat (limited to 'hosts/kay/modules/matrix_sliding_sync.nix')
-rw-r--r--hosts/kay/modules/matrix_sliding_sync.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/hosts/kay/modules/matrix_sliding_sync.nix b/hosts/kay/modules/matrix_sliding_sync.nix
new file mode 100644
index 0000000..f18ef10
--- /dev/null
+++ b/hosts/kay/modules/matrix_sliding_sync.nix
@@ -0,0 +1,14 @@
+{ config, ... }:
+
+let
+ domain = config.userdata.domain;
+in
+{
+ sops.secrets."matrix-${domain}/sliding_sync" = {};
+
+ services.matrix-synapse.sliding-sync = {
+ enable = true;
+ environmentFile = config.sops.secrets."matrix-${domain}/sliding_sync".path;
+ settings.SYNCV3_SERVER = "https://${domain}";
+ };
+}