summaryrefslogtreecommitdiff
path: root/hosts/mox/hardware-configuration.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-11-13 17:31:53 +0530
committersinanmohd <sinan@sinanmohd.com>2023-11-13 18:08:54 +0530
commit8eb0bd9d2c2e39e5f07226d1a8e226514acd9c78 (patch)
treebb8f650236f457ec25c19d83fed8c7e24a57e248 /hosts/mox/hardware-configuration.nix
parentbc838a0c45ed6f6984c87eb6de9c075ad520f7d1 (diff)
hosts/mox: init
Diffstat (limited to 'hosts/mox/hardware-configuration.nix')
-rw-r--r--hosts/mox/hardware-configuration.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/hosts/mox/hardware-configuration.nix b/hosts/mox/hardware-configuration.nix
new file mode 100644
index 0000000..3913e1e
--- /dev/null
+++ b/hosts/mox/hardware-configuration.nix
@@ -0,0 +1,25 @@
+{ modulesPath, ... }:
+
+{
+ imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
+
+ boot.initrd.availableKernelModules = [
+ "ata_piix"
+ "uhci_hcd"
+ "virtio_pci"
+ "virtio_scsi"
+ "sd_mod"
+ "sr_mod"
+ ];
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-uuid/547074b4-4d61-4968-a94f-4f97e1fa2c3c";
+ fsType = "ext4";
+ };
+ "/boot" = {
+ device = "/dev/disk/by-uuid/C634-FE6A";
+ fsType = "vfat";
+ };
+ };
+}