summaryrefslogtreecommitdiff
path: root/modules/userdata.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-09-02 11:45:57 +0530
committersinanmohd <sinan@sinanmohd.com>2023-09-02 11:50:28 +0530
commite441dc43cf5c9707cf580c36805a5aaa66f33b3c (patch)
tree0b86984a3d818ede2c6c42bdb0c63e7e9246cbf1 /modules/userdata.nix
parent06d4452b1d18fd60b0f6adae50992418053f3971 (diff)
module/userdata: init
Diffstat (limited to 'modules/userdata.nix')
-rw-r--r--modules/userdata.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/userdata.nix b/modules/userdata.nix
new file mode 100644
index 0000000..71a5a96
--- /dev/null
+++ b/modules/userdata.nix
@@ -0,0 +1,18 @@
+{ lib, ... }:
+
+let
+ inherit (lib) mkOption types mdDoc;
+in
+{
+ options.userdata = {
+ user = mkOption {
+ type = types.str;
+ default = "sinan";
+ description = mdDoc "owner's username";
+ };
+ groups = mkOption {
+ type = types.listOf types.str;
+ description = mdDoc "Groups the owner should be in";
+ };
+ };
+}