summaryrefslogtreecommitdiff
path: root/nixos/cez/modules/getty.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-05-03 17:56:09 +0530
committersinanmohd <sinan@sinanmohd.com>2024-05-03 17:56:09 +0530
commitbad07776e0f4d6b912c99b9b9aa6ac7ce8940c6b (patch)
tree4bf233489ea44564c52574c0844207860e392c0f /nixos/cez/modules/getty.nix
parentca4b64c69773fba244256efcfb9eda8764e93ca6 (diff)
cez/getty: init
Diffstat (limited to 'nixos/cez/modules/getty.nix')
-rw-r--r--nixos/cez/modules/getty.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/nixos/cez/modules/getty.nix b/nixos/cez/modules/getty.nix
new file mode 100644
index 0000000..725eb4b
--- /dev/null
+++ b/nixos/cez/modules/getty.nix
@@ -0,0 +1,15 @@
+{ config, ... }: let
+ user = config.userdata.name;
+in {
+ systemd.services."getty@".serviceConfig.TTYVTDisallocate = "no";
+
+ services.getty = {
+ loginOptions = "-f ${user}";
+ extraArgs = [
+ "--nonewline"
+ "--skip-login"
+ "--noclear"
+ "--noissue"
+ ];
+ };
+}