summaryrefslogtreecommitdiff
path: root/os/kay/modules/www.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2025-03-06 20:29:05 +0530
committersinanmohd <sinan@sinanmohd.com>2025-03-06 20:29:05 +0530
commitf566c923d860fb3612c99bf1915c9868e67e2109 (patch)
tree073f5d019f0179fc13cb80371a4bf362ee3e9278 /os/kay/modules/www.nix
parent485af822afb205f87b7d74cfbfc312c3bdd3ded3 (diff)
kay/www: move sliding sync to sliding.sinanmohd.com
Diffstat (limited to 'os/kay/modules/www.nix')
-rw-r--r--os/kay/modules/www.nix15
1 files changed, 13 insertions, 2 deletions
diff --git a/os/kay/modules/www.nix b/os/kay/modules/www.nix
index aa989ba..e73b129 100644
--- a/os/kay/modules/www.nix
+++ b/os/kay/modules/www.nix
@@ -57,7 +57,7 @@ in
"/.well-known/matrix/client".return = ''
200 '${builtins.toJSON {
"m.homeserver".base_url = "https://${domain}";
- "org.matrix.msc3575.proxy".url = "https://${domain}";
+ "org.matrix.msc3575.proxy".url = "https://sliding.${domain}";
"m.identity_server".base_url = "https://vector.im";
}}'
'';
@@ -65,8 +65,19 @@ in
"~ ^(\\/_matrix|\\/_synapse\\/client)".proxyPass = "http://127.0.0.1:${toString
config.services.dendrite.httpPort
}";
+ };
+ };
+
+ "sliding.${domain}" = defaultOpts // {
+ extraConfig = ''
+ proxy_buffering off;
+ proxy_request_buffering off;
+ client_max_body_size 0;
+ '';
- "/_matrix/client/unstable/org.matrix.msc3575/sync".proxyPass =
+ locations."/" = {
+ proxyWebsockets = true;
+ proxyPass =
"http://${config.services.matrix-sliding-sync-dirty.settings.SYNCV3_BINDADDR}";
};
};