summaryrefslogtreecommitdiff
path: root/os/pc/modules/wayland.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-04 14:38:25 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-04 18:04:18 +0530
commit654fa9e430be421df30ee79e7ea5f4e40b39dddc (patch)
tree37d9bc759e3e1b3323e76d85d706123f3b799d88 /os/pc/modules/wayland.nix
parent84073038e22d3201ac0176a94527c040bb153e9e (diff)
home, os: refactor
Diffstat (limited to 'os/pc/modules/wayland.nix')
-rw-r--r--os/pc/modules/wayland.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/os/pc/modules/wayland.nix b/os/pc/modules/wayland.nix
new file mode 100644
index 0000000..e609cd9
--- /dev/null
+++ b/os/pc/modules/wayland.nix
@@ -0,0 +1,36 @@
+{ config, ... }: let
+ user = config.global.userdata.name;
+
+ fontSans = config.global.font.sans.name;
+ fontMonospace = config.global.font.monospace.name;
+ fontPackages = config.global.font.monospace.packages
+ ++ config.global.font.sans.packages;
+in {
+ fonts = {
+ packages = fontPackages;
+ enableDefaultPackages = true;
+
+ fontconfig = {
+ hinting.style = "full";
+ subpixel.rgba = "rgb";
+
+ defaultFonts = {
+ monospace = [ fontMonospace ];
+ serif = [ fontSans ];
+ sansSerif = [ fontSans ];
+ };
+ };
+ };
+
+ users.users.${user}.extraGroups = [ "seat" ];
+ services = {
+ seatd.enable = true;
+ dbus = {
+ enable = true;
+ implementation = "broker";
+ };
+ };
+
+ hardware.opengl.enable = true;
+ security.pam.services.swaylock = {};
+}