summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/common.nix b/common.nix
index 008301b..5b5450e 100644
--- a/common.nix
+++ b/common.nix
@@ -2,6 +2,7 @@
let
host = config.networking.hostName;
+ user = config.userdata.user;
in
{
disabledModules = [
@@ -32,6 +33,27 @@ in
};
};
+ users.users.${user} = {
+ extraGroups = [ "wheel" ];
+ packages = with pkgs; [
+ bc
+ unzip
+ htop
+ curl
+ file
+ dig
+ mtr
+ nnn
+ ps_mem
+ brightnessctl
+ ];
+
+ openssh.authorizedKeys.keys = [
+ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIDCeMXhkjm9CabbA/1xdtP9bvFEm8pVXPk66NmI9/VvQ sinan@vex"
+ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIL8LnyOuPmtKRqAZeHueNN4kfYvpRQVwCivSTq+SZvDU sinan@cez"
+ ];
+ };
+
time.timeZone = "Asia/Kolkata";
networking.useDHCP = false;
environment = {