summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 2fe5249..c08c546 100644
--- a/flake.nix
+++ b/flake.nix
@@ -14,9 +14,14 @@
url = "github:sinanmohd/home-manager/sway-generators";
inputs.nixpkgs.follows = "nixpkgs";
};
+
+ alina = {
+ url = "github:sinanmohd/alina";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
};
- outputs = { self, nixpkgs, sops-nix, home-manager, nixos-hardware }: let
+ outputs = { self, nixpkgs, sops-nix, home-manager, nixos-hardware, alina }: let
lib = nixpkgs.lib;
makeGlobalImports = host: [
@@ -34,6 +39,7 @@
specialArgs = { inherit nixos-hardware; };
modules = [
+ alina.nixosModules.alina
sops-nix.nixosModules.sops
./os/${host}/configuration.nix