aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2023-12-27 16:05:41 +0530
committersinanmohd <sinan@sinanmohd.com>2023-12-29 23:22:06 +0530
commit438ad16d03f38e0e444f6ad575078ee949679a86 (patch)
tree0688901d51b9b1736679ac92af5a4636d2553bed /flake.nix
repo: init
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..d6a6346
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,30 @@
+{
+ description = "A passwordstore and Secret Service API implementation";
+
+ inputs.nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
+
+ outputs = { self, nixpkgs }: let
+ lib = nixpkgs.lib;
+
+ supportedSystems = lib.platforms.unix;
+ forSystem = f: system: f {
+ inherit system;
+ pkgs = import nixpkgs { inherit system; };
+ };
+ forAllSystems = f: lib.genAttrs supportedSystems (forSystem f);
+ in {
+ devShells = forAllSystems ({ system, pkgs, ... }: {
+ default = pkgs.mkShell {
+ name = "dev";
+
+ buildInputs = with pkgs; [ gpgme ];
+ shellHook = ''
+ [ -z "$XDG_DATA_HOME" ] &&
+ export XDG_DATA_HOME="$HOME/.local/share"
+ export PASSWORD_STORE_DIR="$XDG_DATA_HOME/debug_pass"
+ export PS1="\033[0;32m[󰟵 ]\033[0m $PS1"
+ '';
+ };
+ });
+ };
+}