aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-04-06 17:35:22 +0530
committersinanmohd <sinan@sinanmohd.com>2024-04-06 17:46:55 +0530
commit4ff6158a6cd29e87222387870e6f01aca41b8183 (patch)
treeeedc21363355691d2bc48d942ebe1cac8db0685d /meson.build
parent246fa34293969eed0ebd650944e52b46c677b054 (diff)
meson: init
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..a0c5988
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,16 @@
+project(
+ 'npass',
+ 'c',
+ version : '0.1',
+ license: 'GPL-3.0-only',
+ default_options : [
+ 'warning_level=3',
+ ]
+)
+
+gpgme_dep = dependency('gpgme', version: '>= 1.0')
+
+npass_inc = include_directories('include')
+
+subdir('libnpass')
+subdir('npass')