aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index c3e1b2b..2d53f76 100644
--- a/flake.nix
+++ b/flake.nix
@@ -20,6 +20,9 @@
buildInputs = with pkgs; [
gpgme
+ systemdLibs
+
+ pkg-config
meson
ninja
@@ -39,20 +42,20 @@
};
});
- packages = forAllSystems ({ system, pkgs }: let
- inherit (pkgs) meson ninja gpgme;
- in {
+ packages = forAllSystems ({ system, pkgs }: {
npass = pkgs.stdenv.mkDerivation (finalAttrs: {
pname = "npass";
version = self.shortRev or self.dirtyShortRev;
src = ./.;
- nativeBuildInputs = [
+ nativeBuildInputs = with pkgs; [
meson
ninja
+ pkg-config
];
- buildInputs = [
+ buildInputs = with pkgs; [
gpgme
+ systemdLibs
];
meta = {