aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..a0c5988
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,16 @@
+project(
+ 'npass',
+ 'c',
+ version : '0.1',
+ license: 'GPL-3.0-only',
+ default_options : [
+ 'warning_level=3',
+ ]
+)
+
+gpgme_dep = dependency('gpgme', version: '>= 1.0')
+
+npass_inc = include_directories('include')
+
+subdir('libnpass')
+subdir('npass')