summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-27 16:13:41 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-30 12:44:01 +0530
commite309091d17720b69c53172a41c0ea45ad7b66911 (patch)
tree166b05fb5dd7de7e0067ef0562567c4878c7050a /flake.nix
parentf3819a764bcac5a4959881795422c8e7b36cf398 (diff)
cmd/bpf: init
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix15
1 files changed, 14 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index c7517df..115172a 100644
--- a/flake.nix
+++ b/flake.nix
@@ -16,9 +16,22 @@
default = pkgs.mkShell {
name = "dev";
- buildInputs = with pkgs; [ go_1_22 gopls jq sqlite ];
+ buildInputs = with pkgs; [
+ go
+ gopls
+
+ jq
+ sqlite
+
+ libbpf
+ ccls
+ clang
+ libllvm
+ ];
shellHook = ''
export PS1="\033[0;36m[ ]\033[0m $PS1"
+ # stop littering eBPF C programs with go:build ignore
+ export CGO_ENABLED=0
'';
};
});