summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..813d633
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,25 @@
+{
+ inputs.nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
+
+ outputs = { self, nixpkgs }: let
+ lib = nixpkgs.lib;
+
+ supportedSystems = lib.platforms.unix;
+ forSystem = f: system: f {
+ inherit system;
+ pkgs = import nixpkgs { inherit system; };
+ };
+ forAllSystems = f: lib.genAttrs supportedSystems (forSystem f);
+ in {
+ devShells = forAllSystems ({ system, pkgs, ... }: {
+ default = pkgs.mkShell {
+ name = "dev";
+
+ buildInputs = with pkgs; [ go_1_22 gopls jq ];
+ shellHook = ''
+ export PS1="\033[0;36m[ ]\033[0m $PS1"
+ '';
+ };
+ });
+ };
+}