summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..9e51d85
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,20 @@
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"
+
+[project]
+name = "walu"
+version = "0.0.1"
+dependencies = [ 'dnspython' ]
+requires-python = ">=3.8"
+
+authors = [{ name="sinanmohd", email="sinan@sinanmohd.com" }]
+description = "captive portal for python"
+classifiers = [
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
+ "Topic :: System :: Operating System Kernels :: Linux"
+]
+
+[project.urls]
+Homepage = "https://git.sinanmohd.com/walu.py"