summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@firemail.cc>2023-09-26 19:41:45 +0530
committersinanmohd <sinan@firemail.cc>2023-09-26 21:05:08 +0530
commit3647b6c1140cb9e0cebeab19e53c0294f966b19b (patch)
treeb4b95fba3c5f1bdb0180005a4d466990ef39a32c /flake.nix
parent1bbbd7a29de5ad21f295bae0c8ac127fb30923bd (diff)
flake: init
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..b6b0cdf
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,30 @@
+{
+ description = "A Wayland Program";
+
+ inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+
+ outputs = { self, nixpkgs }:
+ let
+ supportedSystems = [ "i686-linux" "x86_64-linux" "aarch64-linux" ];
+
+ forAllSystems = f: nixpkgs.lib.genAttrs supportedSystems (system: (forSystem system f));
+
+ forSystem = system: f: f rec {
+ inherit system;
+ pkgs = import nixpkgs { inherit system; };
+ lib = pkgs.lib;
+ };
+ in
+ {
+ devShells = forAllSystems ({ system, pkgs, ...}: {
+ default = pkgs.mkShell {
+ name = "wayland-program";
+
+ buildInputs = with pkgs; [ wayland ];
+ shellHook = ''
+ export PS1="\033[0;33m[󱄄 ]\033[0m $PS1"
+ '';
+ };
+ });
+ };
+}