summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 8421959..e86dc6b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -71,5 +71,24 @@
};
}
);
+ checks = forAllSystems (
+ { system, pkgs, ... }:
+ let
+ inherit (pkgs.lib)
+ filterAttrs
+ isDerivation
+ mapAttrs'
+ nameValuePair
+ pipe
+ ;
+ in
+ pipe self.legacyPackages.${system}.nixosTests [
+ (filterAttrs (_: p: isDerivation p))
+ (mapAttrs' (name: nameValuePair "nixosTests-${name}"))
+ ]
+ // {
+ inherit (self.packages.${system}) evanix evanix-py;
+ }
+ );
};
}