summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorSomeoneSerge <else@someonex.net>2024-08-08 21:16:24 +0000
committerSomeoneSerge <else@someonex.net>2024-08-08 21:16:24 +0000
commit97a78ba6b20cbd60c63b69fcaa4f60e12e46bedb (patch)
tree5b8891468010c9f5518bb63b9455597d970c3043 /flake.nix
parent19c0120754f904c3b0caeb65b3b19d13c4500926 (diff)
flake.nix: add .#checks
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 8421959..e86dc6b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -71,5 +71,24 @@
};
}
);
+ checks = forAllSystems (
+ { system, pkgs, ... }:
+ let
+ inherit (pkgs.lib)
+ filterAttrs
+ isDerivation
+ mapAttrs'
+ nameValuePair
+ pipe
+ ;
+ in
+ pipe self.legacyPackages.${system}.nixosTests [
+ (filterAttrs (_: p: isDerivation p))
+ (mapAttrs' (name: nameValuePair "nixosTests-${name}"))
+ ]
+ // {
+ inherit (self.packages.${system}) evanix evanix-py;
+ }
+ );
};
}