summaryrefslogtreecommitdiff
path: root/os/kay/modules/hurricane.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2025-04-23 00:10:48 +0530
committersinanmohd <sinan@sinanmohd.com>2025-04-23 00:10:48 +0530
commit7e36e8160d2985ffb90f2198c755208cd598cd75 (patch)
treebb197836ff29b2a6e6a7005c8da5d60f9cab5a5b /os/kay/modules/hurricane.nix
parentfcc33bf3c389dbfce80eafcb1fb5287f1beeebc9 (diff)
os/kay/firewall: refactorHEADmaster
Diffstat (limited to 'os/kay/modules/hurricane.nix')
-rw-r--r--os/kay/modules/hurricane.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/os/kay/modules/hurricane.nix b/os/kay/modules/hurricane.nix
index 9aaf1d1..511b213 100644
--- a/os/kay/modules/hurricane.nix
+++ b/os/kay/modules/hurricane.nix
@@ -42,8 +42,12 @@ in
rttablesExtraConfig = "200 hurricane";
};
- firewall.extraCommands =
+ firewall = {
+ extraCommands =
"iptables -A INPUT --proto 41 --source ${remote} --jump ACCEPT";
+ extraStopCommands =
+ "iptables -D INPUT --proto 41 --source ${remote} --jump ACCEPT";
+ };
};
sops.secrets = {