summaryrefslogtreecommitdiff
path: root/os/kay/modules/hurricane.nix
diff options
context:
space:
mode:
Diffstat (limited to 'os/kay/modules/hurricane.nix')
-rw-r--r--os/kay/modules/hurricane.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/os/kay/modules/hurricane.nix b/os/kay/modules/hurricane.nix
index 9aaf1d1..511b213 100644
--- a/os/kay/modules/hurricane.nix
+++ b/os/kay/modules/hurricane.nix
@@ -42,8 +42,12 @@ in
rttablesExtraConfig = "200 hurricane";
};
- firewall.extraCommands =
+ firewall = {
+ extraCommands =
"iptables -A INPUT --proto 41 --source ${remote} --jump ACCEPT";
+ extraStopCommands =
+ "iptables -D INPUT --proto 41 --source ${remote} --jump ACCEPT";
+ };
};
sops.secrets = {